Will TechTool Pro 5 work with Snow Leopard (Mac OS 10.6.x)?

In order to use TechTool Pro 5 with Mac OS 10.6.x (Snow Leopard), you will need to be using TechTool Pro version 5.0.7.  In order to ensure that you are using the latest version of TechTool Pro 5, choose the TechTool Pro 5 menu, and select Check for Updates...  You will then be prompted to update to version 5.0.7.

TechTool Pro 7 is compatible with Mac OS X 10.6.x (Snow Leopard), and has been updated to version 7.0.3.