I can't make a Mac OS 9 device.

Creating a Mac OS 9 profile requires that the operating system in use supports the creation of a Mac OS 9 drive.  In order to create Mac OS 9 devices, you must have Mac OS 10.5.8 or earlier.