Welcome, Guest
Username: Password: Remember me

Search Micromat Forum

Keyword

TOPIC: TTP Agent not responding

TTP Agent not responding 13 Jan 2019 23:48 #10536

My Activity monitor keeps telling me in red that "TechToolProAgent (Not Responding)" while constantly using 3%+ of CPU time.
I cannot tell what effects this might be having on either the computer or the operation of TTP, but it can't be good.
Restarting or Force Quit does not alter this situation.
Can I do anything about this?
iMac 27" late 2009 with 1/2 SSD OSX 10.9.5
The administrator has disabled public write access.

TTP Agent not responding 14 Jan 2019 00:15 #10537

If you force the process to quit using Activity Monitor, it relaunches.

The TechToolProAgent process is used to make the TechTool Protection system preferences pane available in the menu bar, and may have some other minor function. It should not be using 3% of the CPU. On my iMac (mid-2010) running macOS 10.12.6 Sierra, Activity Monitor shows the process using zero percent of the CPU.

Please see this posting that has complete instructions for uninstalling and reinstalling TechTool Pro. If that does not work to resolve the problem, please send a message to This email address is being protected from spambots. You need JavaScript enabled to view it. , including a link to this thread. You will receive a reply by email on Monday. Thank you.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

TTP Agent not responding 14 Jan 2019 02:11 #10538

Thanks very much. Problem seemingly solved!
The administrator has disabled public write access.

TTP Agent not responding 14 Jan 2019 02:22 #10539

You are welcome, and thanks for letting us know that uninstalling and reinstalling the program appears to have solved the problem.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

TTP Agent not responding 14 Jan 2019 02:32 #10540

I should have mentioned that the problem was solved by FORCE QUIT in the TechToolProAgent window, accessed through the Activity Monitor "Information window", after highlighting the TTP Agent item in the CPU list.
FORCE QUIT from the main APPLE menu did not do it, which is curious.
I didn't actually uninstall + re-install.
But many thanks for the various options. I got there!
The administrator has disabled public write access.

TTP Agent not responding 14 Jan 2019 02:43 #10541

You are welcome, and thanks for clarifying which suggestion solved the problem.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.
Time to create page: 0.291 seconds