Welcome, Guest
Username: Password: Remember me

Search Micromat Forum

Keyword

TOPIC: 24 Hours Voume Rebuild still "prechecking structures"

24 Hours Voume Rebuild still "prechecking structures" 07 Aug 2019 13:37 #11288

Yesterday, I turned on an external, 3TB, hard drive attached to my iMac running Mojave, and the disk would not mount (I've regularly used it to store files for about 3 years now). After turning on TechTool Pro 11, I found the drive, but it is "grayed out".

I'm attempting a Volume Rebuild, but the "Rebuild Progress" window has been indicating "Prechecking Structures" for 24 hours now, and not made any progress beyond that. Is that normal?
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 07 Aug 2019 13:52 #11290

The forums are moderated. New postings do not appear until approved by a moderator. I have deleted your duplicate posting.

That seems like a long time for prechecking structures.

The Volume Rebuild process is a read-only process until you click the Replace button in the Technical Comparison window that appears after the new disk directory has been created in RAM. You can quit the process without any damage.

In case there are any relevant error messages that would be useful, please send a message to This email address is being protected from spambots. You need JavaScript enabled to view it. . You will receive a reply by email, and may be asked to send in some additional information, such as an Apple System Information report. Thank you.

I suggest you run the Surface Scan to check the drive for unremapped bad blocks.
MicroMat Inc
Makers of TechTool
Last Edit: 07 Aug 2019 13:54 by micromattech3.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 07 Aug 2019 21:46 #11291

I ran the Surface Scan... no errors were found. I've been running a check of Volume Structures for about 5 hours now... it's only progressed to "Catalog File" so far.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 07 Aug 2019 23:40 #11292

Thanks for the update.

Checking the disk directory files (the Catalog B-Tree and the Extents B-Tree) of a 3 TB drive can take hours, if the volume has many files on it, and especially if the files are fragmented (in more than one piece, called an "extent". Each piece of each file has to be checked.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 08 Aug 2019 17:53 #11293

Just another update of about 12 hours later. TechTool 11 has progressed to "Extended Attributes File", with 4 more levels still to go. I had no idea this would be so time consuming (2 days so far), but if I can recover my files, it will all have been worth it.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 08 Aug 2019 19:22 #11294

The Volume Structures test provides a diagnosis of the disk directory, but it does not make any repairs. The repairs are done by the Volume Rebuild tool, which has already failed. I hope you have contacted This email address is being protected from spambots. You need JavaScript enabled to view it. , as suggested in my first reply.

If you can, please let the Volume Structures test run to completion, because the diagnosis may be of interest in seeing what is going on. Thank you.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 08 Aug 2019 19:28 #11295

Thanks, I do intend to run the diagnostic to completion, and I'll report back with whatever is found.

As to writing to the Help email address, I had interpreted the earlier guidance as "write when you know what the problem is". Based on what you just provided, I'll write to them now, though I still don't know what the problem actually is.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 08 Aug 2019 19:35 #11296

Thanks for your cooperation.

My hope is that one of the system log files will have some error messages relevant to the failed Volume Rebuild.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 09 Aug 2019 03:17 #11297

Well, after almost 40 hours, the Volume Structures test is complete. TechTool Pro 11 is reporting "No Validation Errors Encountered". But that's not the end of it.

I tried the Mount Volume command, and two things have happened:

1. For the first time in almost 3 days, the Hard Drive appeared on my Desktop.

2. However, when I try opening it, the Window opens, and the drive does report that much of the drive is full (which is good!)... but the drive refuses to display the contents... instead, the drive light just blinks and blinks indicating that it is trying to do something.

Then, my laptop crashed... so I couldn't do anything else with TechTool. Frustrating.

I've rebooted my laptop, and now the drive will not mount...its indicator light just keeps blinking.

Any advice would be appreciated.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 09 Aug 2019 04:00 #11298

Another late night update. I left the drive connected... and after about 5 minutes, it displayed the contents of the drive. However, whatever I try to do with the contents (for example, I tried to copy a single file to another drive), it went into about 10 minutes of "blinking" without doing anything... so I cancelled the copy, and my Finder froze.

The good news is that if I wait long enough, the drive mounts on my desktop, and after another long wait, the contents do display correctly.

However, I can't do anything useful with the contents.

Appreciate any advice I can get.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 09 Aug 2019 09:35 #11299

I suspect that the drive is failing. If it were supported by the SMART test, I would suggest running that. Unfortunately, many external drives do not appear in the SMART test.

It is very unusual for a volume to be unable to be rebuilt by the Volume Rebuild tool when the Volume Structures test finds no disk directory errors.

You might as well send your latest findings to This email address is being protected from spambots. You need JavaScript enabled to view it. , so the earlier report can be interpreted in the light of them. Thank you.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 09 Aug 2019 12:30 #11300

Check to make sure that you can copy a file from a volume on another drive to another volume that is not on this 3 TB external drive, just to make sure that the Finder is not corrupted, or cannot connect properly to its copy engine.

Try the drive on another Macintosh, if you have access to one. If you have another cable, try that, and try a different port if you have one.

When you have a crash such as the one you reported. it is preferable to perform a proper shutdown, wait a few minutes, and then reboot, rather than simply restart. A restart may make use of some code held in RAM that could be corrupted (the contents, not the RAM itself) from the crash.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 11 Aug 2019 20:16 #11301

Well, the mystery is solved... but not the way I thought it would be. After a frustrating week of being unable to access this HD, I decided to spend 20 bucks on buying an inexpensive SATA external drive enclosure from Amazon. I got it today, transferred the HD from the previous OWC enclosure to an Inateck one. Note: The OWC enclosure has both USB 3.0 and Firewire 800 ports... though I've only been using the USB 3.0. The Intaeck is USB 3.0 only.

As soon as I connected the Inateck enclosure to my computer, it mounted immediately. I ran a Volume check using TechTool Pro 11, and it passed completely and rapidly. I have access to all my files... hallelujah!

So, what I supposed was a Hard Drive problem turned out to be an Enclosure problem. I think I'll buy another one of these inexpensive enclosures to keep it handy if I run into a similar problem in the future. Lesson learned--- check BOTH the Enclosure and the HD in future.

Thanks for the help... this had a good ending.
The administrator has disabled public write access.

24 Hours Voume Rebuild still "prechecking structures" 11 Aug 2019 20:35 #11302

You are welcome, and thanks for the most pleasant surprise I have seen in these forums in quite some time.

I suspect you were immediately encouraged by seeing how much faster the Volume Structures test ran.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.
Time to create page: 0.381 seconds