Welcome, Guest
Username: Password: Remember me

Search Micromat Forum

Keyword

TOPIC: TechTool Protection preference pane does not load

TechTool Protection preference pane does not load 13 Jan 2019 22:47 #10530

I installed TechTool Pro 10.1.2 on macOS High Sierra 10.13.6, and now when I try to open TechTool Protection, it just gives an error:

Preferences Error
Could not load TechTool Protection preference pane

Console shows error "### com.micromat.TechToolProProtection instantiatePrefPaneObject exception:*** -[NSDistantObject methodSignatureForSelector:]: remote object does not recognize selector: 'prefDict'".

There could be other relevant Console errors, but who knows, since Console has been useless since Sierra.

The installation of TTP 10.1.2 was an upgrade from the TTP 7.0.9 via TechTool Protogo 4.0.5.

Is TechTool Protection unable to read the previous versions settings? Is there a preference file I should delete? Note that it does appear that TechTool Protection is running, just uncontrollably.
The administrator has disabled public write access.

TechTool Protection preference pane does not load 13 Jan 2019 23:00 #10531

Thanks for your clear and detailed report.

There could be something else wrong with the installation, so as long as you have your serial number handy, use the TechTool Pro 10.1.2 installer to uninstall the program. After launching the installer, use the Customize button, and then configure the checkboxes to remove the program (screen captures below). At the end of the process, the installer will state that the program has been installed (rather than removed), but that is simply some text we cannot change in Apple's installer.

Your serial number and the TechTool Pro 10.1.2 installer are in your Available Downloads, at the bottom of your My Account page, linked above.

After uninstalling the program, launch the TechTool Pro installer, reinstall the application, enter your serial number if prompted, then allow the application to install the TechTool Protection system preferences pane. If the preferences pane does not open properly and allow you to configure its features, please send a message to This email address is being protected from spambots. You need JavaScript enabled to view it. . You will receive a reply by email on Monday, and may be asked to send in some additional information, such as an Apple System Information report, and some log files. You will be given guidance on how to find the relevant error logs, and I agree that what was once something easy has now become more difficult.
Attachments:
MicroMat Inc
Makers of TechTool
Last Edit: 13 Jan 2019 23:11 by micromattech3.
The administrator has disabled public write access.

TechTool Protection preference pane does not load 13 Jan 2019 23:08 #10532

Are you missing a step?

It says, "After uninstalling the program, launch the TechTool Pro application...". Don't I need to reinstall after uninstalling?
The administrator has disabled public write access.

TechTool Protection preference pane does not load 13 Jan 2019 23:10 #10533

Yes, I was missing a step. I have edited the instructions. Thank you.
MicroMat Inc
Makers of TechTool
Last Edit: 13 Jan 2019 23:12 by micromattech3.
The administrator has disabled public write access.

TechTool Protection preference pane does not load 13 Jan 2019 23:22 #10534

Uninstalling and reinstalling enabled the TechTool Protection preference pane to load.

However, "Show in Menu Bar" has no effect. Which is weird, because on the first installation it did show in the menu bar.

Note: This isn't important to me; I didn't want it in the menu bar anyway, unless there some significant improvement in menubar functionality since TTP 7.
The administrator has disabled public write access.

TechTool Protection preference pane does not load 13 Jan 2019 23:34 #10535

Thanks for the update.

I have so much in my menu bar (thanks to Istat Menus) that I usually turn that option off. On my iMac (mid-2-120) running macOS 10.12.6 Sierra, turning on the "show in menu bar" feature causes a TechTool Pro item to be added to the menu bar at the left end. The graphic is the same one used for the icon of the TechTool Pro application, but at the size required to fit in the menu bar, it is not something I would recognize instantly.

If the menu bar option continues not to work, please send a message to This email address is being protected from spambots. You need JavaScript enabled to view it. , so we can look into this. Thank you.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.
Time to create page: 0.307 seconds