Welcome, Guest
Username: Password: Remember me

Search Micromat Forum

Keyword

TOPIC: External Disk Won't Mount After Cancelling DiskStudio's Partition Process

External Disk Won't Mount After Cancelling DiskStudio's Partition Process 15 Jun 2011 23:04 #758

  • Eli
  • Eli's Avatar
I have used DiskStudio to create and delete small disk partitions before without a problem. But now, after having DiskStudio create a 100GB partition on my bootable external drive (on which i have used DiskStudio ever since I first purchased the drive), I encountered a major problem. These are the details...

DiskStudio showed 120GB of free space on the main portion or ""master drive"" and I made a 100GB partition. Then an information window appeared, stating that the process would take a long time and to be patient. I proceeded. It seems by this information window that DiskStudio would take some time because file swapping would be necessary to complete the process. The disk I was partitioning had data on it. Once the process began, another information window appeared with a cancel button, stating that it would take 5236 hours to complete the process. After 15 minutes or so, I decided to cancel the process. When DiskStudio returned back to the main window the 100GB partition was created but the master bootable (and partition-able as DiskStudio indicated) portion of the drive would not mount. Even after a couple of attempts to mount it using the mount button, it still would not mount and appeared grayed out. In this window I could see the master portion, it had retained its name and its size, BUT the icon for it was grayed out and that portion of the drive became unmountable.
The only options I have other than the mount button (which doesn't work) is to erase or delete the master partition of the drive. I can not do this, as there is data on the drive that is irreplaceable. My question to MicroMat is :

How can I mount this disk and save my data?

I never had a problem with this drive. It has passed every "smart test" that TechTool Pro performed on it. Disk Utility sees the drive but "exits" on disk verify with an error.
I'm using DiskStudio v1.5.2 on my MabBook Pro 2GHz Intel Core Duo running Tiger 10.4.11. The external drive is a very reliable iOmega 250GB drive.

HELP!
The administrator has disabled public write access.

Re: External Disk Won't Mount After Cancelling DiskStudio's Partition Process 15 Jun 2011 23:50 #759

I am sorry to see that you had this outcome with cancelling the partitioning process. It appears to me that a lot of files needed to be moved in order to split the volume, and I suspect that the progress indicator was not accurate, although moving files can take a long time.

Sometimes, a restart will allow a volume to be mounted that will not mount otherwise. After a restart, see what the Volume Structures test finds, and also check the volume with Disk Utility.

If the master partition mounts after a restart, back up its data to another volume, and then reformat the drive.

For future reference, please do not ever optimize a volume or split a volume without having a backup of the data. The program warns you to have a backup every time you launch it.
MicroMat Inc
Makers of TechTool
The administrator has disabled public write access.

Re: External Disk Won't Mount After Cancelling DiskStudio's Partition Process 16 Jun 2011 04:27 #762

The Volume Structures test and Volume Rebuild feature of TechTool Pro do not require that the volume be initially mounted before they begin.

You should also run the Surface Scan on the drive, in case there is a new unremapped bad block on it.
MicroMat Inc
Makers of TechTool
Last Edit: 16 Jun 2011 04:34 by micromattech3.
The administrator has disabled public write access.
Time to create page: 0.320 seconds